Viewer

  Publishing Proxy Changelog

File: Changelog_waproxy.txt
Size: 3 KBytes
MD5: 9A5D5D74C8686BE0E1E51739D9454154

1.1.5
   - Upgraded OpenSSL to version 1.1.1c (including security fixes).
     > Set "ssl_protocol TLSv1.2 +TLSv1.1 +SSLv3" in conf/waproxy.conf if you
        need support for older protocols (TLSv1.1 or SSLv3).
   - Added SSL certificate auto-renewal (requires WebADM v1.7.3-1).
   - Upgraded embedded Apache to version 2.4.39 (including security fixes).
   - Removed DES-related ciphers from the embedded Apache TLS configuration.
   - Fixed custom ssl_ciphersuite failing when configured in waproxy.conf.
   
1.1.4
   - Upgraded OpenSSL to version 1.0.2q (including security fixes).
   - Use OpenSSL FIPS module 2.0 (FIPS 140-2 certification).
   - SSLCertificateChainFile point to the SSL certificate file.
   - Added ssl_protocol and ssl_ciphersuite in waproxy.conf for changing
     > Apache SSL protocol list and allowed encryption ciphers.
   
1.1.3
   - Upgraded embedded Apache to version 2.4.33 (including security fixes).
   - Updated OpenSSL libraries to version 1.0.2o (including security fixes).
   - Updated SSL protocols and cypher suite to the current recommendations.
   - Fixed Apache segfault with SSL caches.
   - Fixed caching issues.
   - Fixed second server failover.
   - New setup wizard with server URL auto-configuration and SSL certificate
     signed by WebADM CA (Rsignd).
      
1.1.2
   - Added the security modules mod_evasive and mod_reqtimeout for DDoS
     and slow HTTP request attack protection.
   - Added HTTP caching for better performances.
   - Upgraded OpenSSL to version 1.0.2k (security fixes).
   - Added WAProxy backup and restore scripts in the bin/ directory.
     > The scripts can be used for migrating WAProxy to a new server.
   
1.1.1
   - This version of WAProxy is required for use with WebADM >= 1.5.8.
   
1.1.0
   - Upgraded Apache server to version 2.4.25 (security fixes).
   - Upgraded OpenSSL library to version 1.0.2j (security fixes).
   - Added major enhancement to the setup script.
   - Remove RSign setup requirements.
   - Full Web Services proxy support has been removed.
     > Web Services endpoints (OpenOTP & TiQR) are still included.
   - Major code rewrite (please uninstall the old WAProxy first).
     > You need WebADM vervion >= 1.5.7 with this version of WAProxy!
   - Brand new configuration files' directives.
     > Configurations from WAProxy versions 1.0.x are not compatible.
     > You must uninstall WAProxy 1.0.x before installing this version!
     
1.0.3
   - Added a new endpoint for OpenOTP mobile communications with
     Push login and the RCDevs Authenticator.
   - Upgraded Apache to version 2.4.23 and OpenSSL to version 1.0.2h.